Active1 year ago

RPM resource glibc-devel. Object files for development using standard C libraries. The glibc-devel package contains the object files necessary for developing programs which use the standard C libraries (which are used by nearly all programs). BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 On Saturday 21 December 2002 07:50 am, Ekow Oppon wrote: > Hi guys, Need this rpm urgently to intall gcc-3.27 on RH8.0 > Please help! Glibc-devel Download for Linux (rpm, i386, i586, i686. Glibc-devel-2.27-12.mga7.x86_64.rpm: Header and object files for development using standard C libraries.

I am trying to install packages, but I keep getting dependency errors.

I already installed the EPEL, IUS, REMI repos.

Example:

and I get

and when I try to install glibc (or the other dependencies)

I get

does not show any glibc-devel installed.

RHEL Version = 2.6.32-358.el6.x86_64

Jeff Schaller
49.7k11 gold badges73 silver badges165 bronze badges
JasonJason

2 Answers

You should be installing the gcc package from

slc6-os.repo or slc6-updates.repo

Then the dependancies will be provided from there too rather than using the devtoolset version.

Glibc-devel-2.2.90-12

Gunship Battle Helicopter 2.2.90 Mod Apk

Yum Repositories Entries

Location:

slc6-os.repo
slc6-updates.repo
slc6-extras.repo

Import the GPG key:

geedoubleyageedoubleya

glibc-devel should be part of the base repo, you may have a some conflicts with your repos.

try disabling all the extra repos you added and try again.

You should also check yum Priorities plug-in which can prevent a 3rd party repository from replacing base packages, or prevent base/updates from replacing a 3rd party package.

RabinRabin
2,7181 gold badge11 silver badges21 bronze badges

Not the answer you're looking for? Browse other questions tagged rhelpackage-managementrepository or ask your own question.

Who Were Johnny Carson Guest On 2/2/90

Hi,
OS : Oracle Enter Prise Linux 6 (equivalent to RedHat)
I am in process to install oracle 10g on said OS.My process fails and after digging up , I came to know that some of the oracle libraries are compiled on 32-bit architecture and it require glibc-32 bit . also it require for gcc-32 bit.
Now i have downloaded all the required rpm for gcc-32bit . when I try to install glibc and its dependencies , it gives me error that newer version already exist.
Can you please tell me how can I install , Gcc-32bit(libgc, libstd-i386 etc) in parallel or standalone?
[[email protected] rpm-32bit]# rpm -ivh glibc-2.3.2-95.37.i386.rpm
warning: glibc-2.3.2-95.37.i386.rpm: Header V3 DSA/SHA1 Signature, key ID 0c98ff9d: NOKEY
error: Failed dependencies:
glibc-common = 2.3.2-95.37 2.3.2-95.37.i386
[[email protected] rpm-32bit]# rpm -ivh glibc-common-2.3.2-95.37.i386.rpm
warning: glibc-common-2.3.2-95.37.i386.rpm: Header V3 DSA/SHA1 Signature, key ID 0c98ff9d: NOKEY
error: Failed dependencies:
glibc > 2.3.2 conflicts with glibc-common-2.3.2-95.37.i386
[[email protected] rpm-32bit]# rpm -qa grep glib
pulseaudio-libs-glib2-0.9.21-13.el6.x86_64
poppler-glib-0.12.4-3.el6.x86_64
taglib-1.6.1-1.1.el6.x86_64
avahi-glib-0.6.25-8.el6.x86_64
compat-glibc-7.x-2.2.4.32.6.i386
glibc-common-2.12-1.25.el6.x86_64
NetworkManager-glib-0.8.1-5.el6.x86_64
glibmm24-2.22.1-1.el6.x86_64
glib2-2.22.5-5.el6.x86_64
glibc-2.12-1.25.el6.x86_64
dbus-glib-0.86-5.el6.x86_64
PackageKit-glib-0.5.8-13.el6.x86_64
[[email protected] rpm-32bit]# rpm -ivh glibc-common-2.3.2-95.37.i386.rpm
warning: glibc-common-2.3.2-95.37.i386.rpm: Header V3 DSA/SHA1 Signature,
key ID 0c98ff9d: NOKEY
error: Failed dependencies:
glibc > 2.3.2 conflicts with glibc-common-2.3.2-95.37.i386
regarrds,
tanveer